0
Under review

Oops! In-app purchases not available at this moment! e-1029

MintUmbrellas 2 months ago in Android • updated by MintUmbrellas 1 month ago 10

 When I go to add music to my animation a popup tab opens that says 'Premium Features' at the top, and the only thing that shows up on the tab is a message saying 'Oops! In-app purchases not available at this moment! e-1029'. I have already purchased this feature and the premium features tab shouldn't even open. It also won't let me add more than three layers, when it should let me add up to six because I purchased that feature too. This has only happened recently with the new update.

Under review

Hello,

1. When you go to FlipaClip settings, under Premium Features do you see checkmarks beside "More layer options" and "Add your own audio"?

2. Have you recently switched your Google Play accounts?

1.  When I open Premium Features the only thing that shows up is the same error message as before.

2. No

Under review

Your payments are connected to your Google play account and in-app purchases will be restored automatically after installing or updating FlipaClip as long as you are logged into the original Google Play account that made the purchase.

Please make sure that when you install or update FlipaClip you use the original account that made the purchase. <<< this is very important!


Please see this forum post for more help. 

Let me know if it helps or you still have the issue :)

Best,

Dusan

So I should uninstall and reinstall Flipaclip? I'll backup my projects beforehand to keep them safe. I'll let you know if this works.

Under review

Please note that project backup is also a paid feature. Does that feature work for you?

Also, you don't need to reinstall. You just need to add the original account that made the purchase to your Google Play app and premium features should appear automatically.

If it doesn't work automatically try to restart your phone and clear data and cache from Google Play app.

Nevermind I accidentally uninstalled Flipaclip without backing anything up. Great. Now most of my animations are gone. I still have backups of some of my animations from before though, but how do you import them back into Flipaclip?

Ahh, I am really sorry for that :(

Did you at least get your premium features back?

To import projects you just need to find backup files and try to open, it should automatically recognize the format and ask you if you want to open using FlipaClip.

No, sadly the same error message is there. When I tap on the file to open it it doesn't recognize it at all, it says that I don't have any applications that can open that type of file. The file type is .fc

Please check the link below and try Step 2: Clear cache & data of the Play Store:

https://support.google.com/googleplay/answer/7513003?hl=en

If that doesn't help send us a bug report so we can check if there is an error in the code.

Right after this issue happens (when you open premium features and message appears) go to FlipaClip settings (gear icon on the top left) then find “Debug” and click on “Bug Report”. It will generate a file that you can either email to us or attach it here.

If you are emailing it just let me know here once you send it and from which email you sent so we can find it easier :)

Thanks,

Dusan

 I sent the bug report from the email I use here. Sorry for not replying for so long. I kinda gave up for a while. I hope we can fix this still.